Feed not available at this time! Error message:after deploying SPRSS.wsp

Jan 19, 2009 at 11:57 AM
Edited Jan 21, 2009 at 11:34 AM
I have deployed SPRSS.wsp on the server and everything is working fine on the server, the feeds are getting displayed in the site, I have read the rss feeds of a list within an intranet portal.Everything is working fine on server, but when other users login through remote systems it is giving the error below:

Feed not available at this time! Error message:
System.Net.WebException: The remote server returned an error: (401) Unauthorized.
at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
at System.Net.WebClient.DownloadData(Uri address)
at System.Net.WebClient.DownloadData(String address)
at SPRSS.WebParts.RSSRender.Render(HtmlTextWriter writer)
HOL_DEV\tamkeen.khan
RSS Url: http://siteurl/_layouts/listfeed.aspx?List=%7B6A970885%2D8FD6%2D45B8%2DBF37%2D41D766EAAABF%7D

Please let me know where is the problem and help me to solve this error.
Jan 21, 2009 at 11:10 AM
Edited Jan 21, 2009 at 11:35 AM
I have solved the error by changing the 

  wc.Credentials = System.Net.CredentialCache.DefaultCredentials; by the below code

System.Net.WebClient wc = new System.Net.WebClient();
                wc.Credentials = new System.Net.NetworkCredential(username, password);

              

Apr 20, 2009 at 10:34 AM
I'm getting the same error message. Can you please provide step-by-step instructions on how I can modify the code myself?
Jul 6, 2009 at 3:28 AM
Edited Jul 6, 2009 at 3:28 AM

Unfortunately, I got the same error message when added the RSS Web Part to the homepage. Please advise if there is any workaround?